Discussion Forums - Forums for discussion of accessible web site design
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister  Content Enhanced - Use Any Browser
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Posts to this forum are now disabled due to low use and abuse by spammers.

Javascript that works in Firefox, not in IE

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Any Browser Forums Forum Index -> Browser Issues
View previous topic :: View next topic  
Author Message
xxlken



Joined: 04 Dec 2008
Posts: 4

PostPosted: Thu Dec 04, 2008 12:54 pm    Post subject: Javascript that works in Firefox, not in IE Reply with quote

I'm building a site for myself and also for a grade in a class. I have a page of thumbnail pictures. When clicked, thanks to a javascript, a smaller window should open with the larger picture that the thumbnail represents. It works perfectly in Firefox. In IE, nothing happens when I click a thumbnail.

The javascript is called out in the HTML file like this:

<script type="text/javascript">
<!--
function MM_openBrWindow(theURL,winName,features) { //v2.0
window.open(theURL,winName,features);
}
//-->
</script>

Here's an example of how the javascript is called from an IMG tag:

onclick="MM_openBrWindow('assets/images/haley/prego.jpg','babyInside','width=635,height=888'

Please, can anyone tell me what to do so that IE will respond as Firefox does?
Back to top
View user's profile Send private message Send e-mail Visit poster's website
joerelman



Joined: 29 Apr 2005
Posts: 65
Location: Near Ghent, Belgium

PostPosted: Fri Dec 05, 2008 12:40 am    Post subject: Reply with quote

Is it a typo or did you forget the closing parenthesis and double-quote for the onclick?
_________________
If it ain't broke, don't fix it
http://www.desonville.net/
Back to top
View user's profile Send private message Visit poster's website
xxlken



Joined: 04 Dec 2008
Posts: 4

PostPosted: Fri Dec 05, 2008 8:40 am    Post subject: Just a typo Reply with quote

The closing paren is indeed in my code, so the problem is elsewhere.

One thing I've noticed... the target file is a JPG, the image itself. It is not an HTML file that contains the image. Can the problem be that Firefox can accept a JPG target and IE cannot?
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Adrian



Joined: 04 Jun 2007
Posts: 52

PostPosted: Fri Dec 05, 2008 10:47 am    Post subject: Re: Just a typo Reply with quote

xxlken wrote:
The closing paren is indeed in my code, so the problem is elsewhere.

One thing I've noticed... the target file is a JPG, the image itself. It is not an HTML file that contains the image. Can the problem be that Firefox can accept a JPG target and IE cannot?


Can you show us a live page?
_________________
Adrian

Rayfields accessibility consultancy - Independent Testers - Breakofday
Back to top
View user's profile Send private message Visit poster's website
xxlken



Joined: 04 Dec 2008
Posts: 4

PostPosted: Sat Dec 06, 2008 8:55 am    Post subject: Live page Reply with quote

You betcha, Adrian.

Go to http://www.kenigma.us/haley.html on IE and click on any of the thumbnails there. Does a larger picture open? Not on my PC.

It might work for you. I called my son, asked him to try it, and he succeeded. So the problem might be in one of my IE settings, but which one? Any ideas?
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Adrian



Joined: 04 Jun 2007
Posts: 52

PostPosted: Sat Dec 06, 2008 10:50 am    Post subject: Re: Live page Reply with quote

xxlken wrote:
You betcha, Adrian.

Go to http://www.kenigma.us/haley.html on IE and click on any of the thumbnails there. Does a larger picture open? Not on my PC.

It might work for you. I called my son, asked him to try it, and he succeeded. So the problem might be in one of my IE settings, but which one? Any ideas?


I've looked at the site and the larger images load fine, I tried about 6.

I'm using IE 6. What are you using?

Have you got JavaScript turned off? I tried it with it turned off and the larger images don't load.

To check do the following:

In IE, go to Tools > Internet Options > Security > Custom Level

Then look for 'Active Scripting' (near the bottom of list) and see if it is enabled or disabled.
_________________
Adrian

Rayfields accessibility consultancy - Independent Testers - Breakofday
Back to top
View user's profile Send private message Visit poster's website
xxlken



Joined: 04 Dec 2008
Posts: 4

PostPosted: Sun Dec 07, 2008 12:26 am    Post subject: No luck Reply with quote

I checked, Adrian. Active scripting was already enabled.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Adrian



Joined: 04 Jun 2007
Posts: 52

PostPosted: Sun Dec 07, 2008 12:56 am    Post subject: Re: No luck Reply with quote

xxlken wrote:
I checked, Adrian. Active scripting was already enabled.


What verson of IE are you using?

If it's IE 7 have you checked all the setting, such as pop up blocker?
_________________
Adrian

Rayfields accessibility consultancy - Independent Testers - Breakofday
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Any Browser Forums Forum Index -> Browser Issues All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
This board is protected by Phpbbantispam
Powered by phpBB © 2001, 2005 phpBB Group